You are here: Home / Open Source Projects / Xfce installers
German
English
Tuesday, 2018-08-21

Overview

xfce

This installer allows easy and platform-independent installation of the Xfce desktop environment.

 

Requirements

  • Gtk+ 2.2 devel files (or higher) have to be installed. The corresponding debian-package is libgtk2.0-dev, RedHat/Fedora/SuSE-user need the package gtk2-devel.
  • In addition, the libraries libICE and libSM are required for installation of Xfce. The corresponding debian-packages are libice-dev and libsm-dev. Redhat/Fedora/SuSE-user need either XFree86-devel or xorg-x11-devel.

Howto

First, download this file:

Once the download has completed successfully, the file has to be marked executable:

$ chmod +x xfce4-4.2.1.1-installer.bin

If you want to install Xfce systemwide, perform the following steps:

$ xhost +localhost
$ su
# ./xfce4-4.2.1.1-installer.bin

In case you don't have root access to the system, you can choose to install the software for your user-account only. Proceed with the following command:

$ ./xfce4-4.2.1.1-installer.bin

Further information on usage of the installation wizard and about potentially occuring problems can be found in the online-documentation.